1. Убедительно прошу ознакомиться с правилами публикации программного обеспечения. Помимо VT нужен еще Hybrid Analysis. Подробнее описано в правилах ресурса, пункт 1.19.2.
    Скрыть объявление
  2. На форуме стала доступна баннерная реклама. Все подробности в теме: Реклама на форуме [баннеры]
    Скрыть объявление
  3. Do you speak English? Use the English version of the site! Link
    Скрыть объявление
  4. Нет желания и времени зарабатывать репутацию? Покупка группы "Пользователь" решит часть проблем, а "VIP" - все. Подробнее по ссылке.
    Скрыть объявление
Скрыть объявление
Здравствуй гость! После регистрации на ресурсе, ты сможешь скачивать материалы с форума и участвовать в его жизни! Для регистрации откройте соответствующую форму или нажмите на эту ссылку.

Устанавливаем metasploit framework dev на windows

Тема в разделе "Способы", создана пользователем D.Evenjo, 16.10.2015.

  1. D.Evenjo

    D.Evenjo Юзер

    Авг 13 2017 в 20:36
    Регистрация:
    09.09.2015
    Сообщения:
    398
    Симпатии:
    146
    Антипатии:
    0
    acb5854e2413dd4b94a33f2a4d3ed77a.png
    Всем привет! После выхода Metasploit Community, которая мне очень не понравилась, я задался вопросом как же вернуть привычную для меня структуру этого инструмента. И решил я этот вопрос для себя, скачав и настроив dev версию. И всё было хорошо, пока недавно мне не пришлось настраивать тоже самое на Windows. Кого интересует данная проблема прошу под кат.


    На самом деле пишу эти строки больше для себя, чтобы при повторном появлении проблемы не наступать на те же самые грабли, но если данная информация будет востребована сообществом, то будет очень хорошо.
    Как ни странно, но скачивание ветки metasploit будет практически последним этапом, а в начале приготовления к этому.
    1. Установка Git for Windows
    Т.к. metasploit полностью переехал на git, то без него никуда, поэтому качаем Ссылки могут видеть только зарегистрированные пользователи. Зарегистрируйтесь или авторизуйтесь для просмотра ссылок! и устанавливаем его. Установка у него банальная, поэтому заострять внимание на ней я не буду.

    2. Установка Ruby 1.9.3
    Все знают, что при использовании metasploit без Ruby никуда, поэтому следующим шагом нам нужно установить Ruby.
    Для этого качаем установщик Ruby 1.9.3 для Windows Ссылки могут видеть только зарегистрированные пользователи. Зарегистрируйтесь или авторизуйтесь для просмотра ссылок! и запускаем его. Установка Ruby тоже не должна вызвать у вас проблем, но обратите, пожалуйста, внимание на один момент — не забудьте поставить галочку напротив пункта «Add Ruby executables to your PATH», чтобы впоследствии не возиться с путями к Ruby.
    a451d4e8b56401f6f8232c45192f9acb.png

    3. Установка Development Kit для Ruby и настройка WinPcap
    Так же для правильной работы Metasploit нам потребуется Ссылки могут видеть только зарегистрированные пользователи. Зарегистрируйтесь или авторизуйтесь для просмотра ссылок!, который можно скачать по той же ссылке, что и сам Ruby. После того как вы его скачали, скопируйте его в папку, в которую вы его хотите распаковать(у меня это c:\rubydk) и распакуйте. Так же нам в дальнейшем понадобиться пакет pcaprub, а для него нужно скачать и установить Ссылки могут видеть только зарегистрированные пользователи. Зарегистрируйтесь или авторизуйтесь для просмотра ссылок! и Ссылки могут видеть только зарегистрированные пользователи. Зарегистрируйтесь или авторизуйтесь для просмотра ссылок!.
    С установкой WinPcap, я думаю, ни у кого проблем не возникнет. В DevPack'е нас интересует две папки — /lib и /include. Содержимое папки lib нужно скопировать в папку lib, которая находится в папке с установленным Ruby, а содержимое папки Include в папку Include/ruby-1.9.1, которая также находится в папке Ruby.
    Ну и для завершения установки DevKit нам осталось вызвать командную строку, перейти в папку с DevKit'ом и выполнить две команды:
    Код:
    ruby dk.rb init
    ruby dk.rb install
    fc9f5e3545392416ad23458966b3b5ae.png
    И если никаких ошибок не высветиться, то с этим этапом покончено.

    4. Клонирование ветки Metasploit Framework и подготовка к запуску
    Вот мы и подошли к самому Metasploit Framework. Итак для начала скланируем его, выполнив следующую команду:
    Код:
    git clone git://github.com/rapid7/metasploit-framework.git c:\git
    Так же для корректной работы Metasploit Framework нам нужно установит необходимые gem'сы и выполнить msfupdate. Для этого выполним следующие комманды:
    Код:
    gem install bundler
    ruby c:\git\metasploit-framework\msfupdate
    И если всё выполнилось удачно, то вы получили последнюю рабочую версию Metasploit Framework Dev. Теперь вы можете выполнить:
    Код:
    ruby c:\git\metasploit-framework\msfconsole
    и начать работать.
    db646a475581193a2f2405cd0f8ba5e2.png

    А можете дополнительно поставить Msfgui как я. Для этого Ссылки могут видеть только зарегистрированные пользователи. Зарегистрируйтесь или авторизуйтесь для просмотра ссылок! архив его ветки с github'а, из архива скопируйте файл msfgui.exe и папку dist в папку metasploit-framework и запустите msfgui.
    eecfadb5e4b64c7c5e01381bedf39df3.png
     
Похожие темы
  1. AnGel
    Ответов:
    1
    Просмотров:
    3.855
  2. AnGel
    Ответов:
    6
    Просмотров:
    261
  3. AnGel
    Ответов:
    0
    Просмотров:
    138
  4. hack-anonim
    Ответов:
    0
    Просмотров:
    177
  5. Zer0neX
    Ответов:
    2
    Просмотров:
    245
Загрузка...
Загрузка...